Discussion:
about lftp using socks5
(too old to reply)
huwenhuo
2009-05-12 02:16:54 UTC
Permalink
hi,

would anyone told me how to use socks5 proxy for lftp?

i am not sure this is the right mailing list to find things about the
usage of lftp. ^_^

thanks for any advice!
Justin Piszcz
2009-05-12 12:49:14 UTC
Permalink
Post by huwenhuo
hi,
would anyone told me how to use socks5 proxy for lftp?
i am not sure this is the right mailing list to find things about the usage
of lftp. ^_^
thanks for any advice!
Hi,

1. You need SOCKS support compiled in.
2. Then you need to export the SOCKS5_PROXY or SOCKS_PROXY environment
variables.

Then when you use lftp it will use the socks proxy you have defined.

Justin.
huwenhuo
2009-05-13 13:22:49 UTC
Permalink
Hi,

thanks Justin very much.

i set proxy like this:

export SOCKS5_PROXY=username:***@159.226.42.229:1080 or

export SOCKS_PROXY=username:***@159.226.42.229:1080

but it does not work.

any advice?




sincerely,


wenhuo hu
Post by Justin Piszcz
Post by huwenhuo
hi,
would anyone told me how to use socks5 proxy for lftp?
i am not sure this is the right mailing list to find things about the
usage of lftp. ^_^
thanks for any advice!
Hi,
1. You need SOCKS support compiled in.
2. Then you need to export the SOCKS5_PROXY or SOCKS_PROXY environment
variables.
Then when you use lftp it will use the socks proxy you have defined.
Justin.
Justin Piszcz
2009-05-13 14:50:00 UTC
Permalink
Does your lftp have socks support compiled in?

ldd /usr/bin/lftp

What does this show?

Justin.
Post by huwenhuo
Hi,
thanks Justin very much.
but it does not work.
any advice?
sincerely,
wenhuo hu
Post by Justin Piszcz
Post by huwenhuo
hi,
would anyone told me how to use socks5 proxy for lftp?
i am not sure this is the right mailing list to find things about the
usage of lftp. ^_^
thanks for any advice!
Hi,
1. You need SOCKS support compiled in.
2. Then you need to export the SOCKS5_PROXY or SOCKS_PROXY environment
variables.
Then when you use lftp it will use the socks proxy you have defined.
Justin.
huwenhuo
2009-05-13 23:38:47 UTC
Permalink
hi,

I installed lftp by packages. I am using freebsd 7.1-RELEASE. My laptop
cannot afford to compile programs from source code by ports. So I do not
know whether my lftp was compiled with socks suports.

the following is the "ldd lftp: result:

[~]$ldd /usr/local/bin/lftp
/usr/local/bin/lftp:
libexpat.so.6 => /usr/local/lib/libexpat.so.6 (0x2812c000)
libssl.so.5 => /usr/lib/libssl.so.5 (0x2814c000)
libcrypto.so.5 => /lib/libcrypto.so.5 (0x2818d000)
libintl.so.8 => /usr/local/lib/libintl.so.8 (0x282e6000)
libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x282ef000)
libreadline.so.7 => /lib/libreadline.so.7 (0x283e4000)
libutil.so.7 => /lib/libutil.so.7 (0x28416000)
libncurses.so.7 => /lib/libncurses.so.7 (0x28424000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x28463000)
libm.so.5 => /lib/libm.so.5 (0x28558000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2856d000)
libc.so.7 => /lib/libc.so.7 (0x28578000)



wenhuo hu
Post by Justin Piszcz
Does your lftp have socks support compiled in?
ldd /usr/bin/lftp
What does this show?
Justin.
Post by huwenhuo
Hi,
thanks Justin very much.
but it does not work.
any advice?
sincerely,
wenhuo hu
Post by Justin Piszcz
Post by huwenhuo
hi,
would anyone told me how to use socks5 proxy for lftp?
i am not sure this is the right mailing list to find things about
the usage of lftp. ^_^
thanks for any advice!
Hi,
1. You need SOCKS support compiled in.
2. Then you need to export the SOCKS5_PROXY or SOCKS_PROXY environment
variables.
Then when you use lftp it will use the socks proxy you have defined.
Justin.
Justin Piszcz
2009-05-14 08:03:15 UTC
Permalink
Hello,

Then SOCKS support will not work, it should look something like this:

ldd /usr/bin/lftp
linux-gate.so.1 => (0xffffe000)
libgcc_s.so.1 => /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.2/libgcc_s.so.1 (0x40034000)
libstdc++.so.5 => /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.2/libstdc++.so.5 (0x4003d000)
libreadline.so.4 => /lib/libreadline.so.4 (0x400f3000)
libssl.so.0.9.7 => /usr/lib/libssl.so.0.9.7 (0x40121000)
libcrypto.so.0.9.7 => /usr/lib/libcrypto.so.0.9.7 (0x40152000)
libsocks.so.0 => /usr/lib/libsocks.so.0 (0x4024d000) <- You need this.
libpam.so.0 => /lib/libpam.so.0 (0x40286000)
libnsl.so.1 => /lib/libnsl.so.1 (0x4028e000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0x402a3000)
libutil.so.1 => /lib/libutil.so.1 (0x402d1000)
libresolv.so.2 => /lib/libresolv.so.2 (0x402d4000)
libdl.so.2 => /lib/libdl.so.2 (0x402e6000)
libm.so.6 => /lib/libm.so.6 (0x402e9000)
libc.so.6 => /lib/libc.so.6 (0x4030b000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

Justin.
Post by huwenhuo
hi,
I installed lftp by packages. I am using freebsd 7.1-RELEASE. My laptop
cannot afford to compile programs from source code by ports. So I do not know
whether my lftp was compiled with socks suports.
[~]$ldd /usr/local/bin/lftp
libexpat.so.6 => /usr/local/lib/libexpat.so.6 (0x2812c000)
libssl.so.5 => /usr/lib/libssl.so.5 (0x2814c000)
libcrypto.so.5 => /lib/libcrypto.so.5 (0x2818d000)
libintl.so.8 => /usr/local/lib/libintl.so.8 (0x282e6000)
libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x282ef000)
libreadline.so.7 => /lib/libreadline.so.7 (0x283e4000)
libutil.so.7 => /lib/libutil.so.7 (0x28416000)
libncurses.so.7 => /lib/libncurses.so.7 (0x28424000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x28463000)
libm.so.5 => /lib/libm.so.5 (0x28558000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2856d000)
libc.so.7 => /lib/libc.so.7 (0x28578000)
wenhuo hu
Post by Justin Piszcz
Does your lftp have socks support compiled in?
ldd /usr/bin/lftp
What does this show?
Justin.
Post by huwenhuo
Hi,
thanks Justin very much.
but it does not work.
any advice?
sincerely,
wenhuo hu
Post by Justin Piszcz
Post by huwenhuo
hi,
would anyone told me how to use socks5 proxy for lftp?
i am not sure this is the right mailing list to find things about the
usage of lftp. ^_^
thanks for any advice!
Hi,
1. You need SOCKS support compiled in.
2. Then you need to export the SOCKS5_PROXY or SOCKS_PROXY environment
variables.
Then when you use lftp it will use the socks proxy you have defined.
Justin.
huwenhuo
2009-05-14 16:13:31 UTC
Permalink
Dear Justin,

I tried to compile lftp by

make CONFIGURE_ARGS+=--with-socks5 install

but it popped up a windows for choosing the configure arguments, and i
noticed there is no socks item in that list. when it ended installation.
lftp still cannot use socks5, and the result of "ldd
/usr/local/bin/lftp" seems there is not difference before i reinstall.
it seems there are no way to set socks5 supports in freebsd?

[~]$ldd /usr/local/bin/lftp
/usr/local/bin/lftp:
libexpat.so.6 => /usr/local/lib/libexpat.so.6 (0x2813e000)by the w
libgnutls.so.26 => /usr/local/lib/libgnutls.so.26 (0x2815e000)
libz.so.4 => /lib/libz.so.4 (0x28205000)
libgcrypt.so.15 => /usr/local/lib/libgcrypt.so.15 (0x28217000)
libgpg-error.so.0 => /usr/local/lib/libgpg-error.so.0 (0x2827f000)
libintl.so.8 => /usr/local/lib/libintl.so.8 (0x28283000)
libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x2828c000)
libreadline.so.7 => /lib/libreadline.so.7 (0x28381000)
libutil.so.7 => /lib/libutil.so.7 (0x283b3000)
libncurses.so.7 => /lib/libncurses.so.7 (0x283c1000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x28400000)
libm.so.5 => /lib/libm.so.5 (0x284f5000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2850a000)
libc.so.7 => /lib/libc.so.7 (0x28515000)


it seems i cannot do it. thanks!

wenhuo hu
Post by Justin Piszcz
Hello,
ldd /usr/bin/lftp
linux-gate.so.1 => (0xffffe000)
libgcc_s.so.1 =>
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.2/libgcc_s.so.1 (0x40034000)
libstdc++.so.5 =>
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.2/libstdc++.so.5 (0x4003d000)
libreadline.so.4 => /lib/libreadline.so.4 (0x400f3000)
libssl.so.0.9.7 => /usr/lib/libssl.so.0.9.7 (0x40121000)
libcrypto.so.0.9.7 => /usr/lib/libcrypto.so.0.9.7 (0x40152000)
libsocks.so.0 => /usr/lib/libsocks.so.0 (0x4024d000) <- You need this.
libpam.so.0 => /lib/libpam.so.0 (0x40286000)
libnsl.so.1 => /lib/libnsl.so.1 (0x4028e000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0x402a3000)
libutil.so.1 => /lib/libutil.so.1 (0x402d1000)
libresolv.so.2 => /lib/libresolv.so.2 (0x402d4000)
libdl.so.2 => /lib/libdl.so.2 (0x402e6000)
libm.so.6 => /lib/libm.so.6 (0x402e9000)
libc.so.6 => /lib/libc.so.6 (0x4030b000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
Justin.
Post by huwenhuo
hi,
I installed lftp by packages. I am using freebsd 7.1-RELEASE. My
laptop cannot afford to compile programs from source code by ports.
So I do not know whether my lftp was compiled with socks suports.
[~]$ldd /usr/local/bin/lftp
libexpat.so.6 => /usr/local/lib/libexpat.so.6 (0x2812c000)
libssl.so.5 => /usr/lib/libssl.so.5 (0x2814c000)
libcrypto.so.5 => /lib/libcrypto.so.5 (0x2818d000)
libintl.so.8 => /usr/local/lib/libintl.so.8 (0x282e6000)
libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x282ef000)
libreadline.so.7 => /lib/libreadline.so.7 (0x283e4000)
libutil.so.7 => /lib/libutil.so.7 (0x28416000)
libncurses.so.7 => /lib/libncurses.so.7 (0x28424000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x28463000)
libm.so.5 => /lib/libm.so.5 (0x28558000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2856d000)
libc.so.7 => /lib/libc.so.7 (0x28578000)
wenhuo hu
Post by Justin Piszcz
Does your lftp have socks support compiled in?
ldd /usr/bin/lftp
What does this show?
Justin.
Post by huwenhuo
Hi,
thanks Justin very much.
but it does not work.
any advice?
sincerely,
wenhuo hu
Post by Justin Piszcz
Post by huwenhuo
hi,
would anyone told me how to use socks5 proxy for lftp?
i am not sure this is the right mailing list to find things about
the usage of lftp. ^_^
thanks for any advice!
Hi,
1. You need SOCKS support compiled in.
2. Then you need to export the SOCKS5_PROXY or SOCKS_PROXY
environment
variables.
Then when you use lftp it will use the socks proxy you have defined.
Justin.
Justin Piszcz
2009-05-15 08:02:03 UTC
Permalink
You need to install the socks library first, either dante or the original
SOCKS version and its headers on your system, then try --with-socks again.

Justin.
Post by huwenhuo
Dear Justin,
I tried to compile lftp by
make CONFIGURE_ARGS+=--with-socks5 install
but it popped up a windows for choosing the configure arguments, and i
noticed there is no socks item in that list. when it ended installation. lftp
still cannot use socks5, and the result of "ldd /usr/local/bin/lftp" seems
there is not difference before i reinstall. it seems there are no way to set
socks5 supports in freebsd?
[~]$ldd /usr/local/bin/lftp
libexpat.so.6 => /usr/local/lib/libexpat.so.6 (0x2813e000)by the w
libgnutls.so.26 => /usr/local/lib/libgnutls.so.26 (0x2815e000)
libz.so.4 => /lib/libz.so.4 (0x28205000)
libgcrypt.so.15 => /usr/local/lib/libgcrypt.so.15 (0x28217000)
libgpg-error.so.0 => /usr/local/lib/libgpg-error.so.0 (0x2827f000)
libintl.so.8 => /usr/local/lib/libintl.so.8 (0x28283000)
libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x2828c000)
libreadline.so.7 => /lib/libreadline.so.7 (0x28381000)
libutil.so.7 => /lib/libutil.so.7 (0x283b3000)
libncurses.so.7 => /lib/libncurses.so.7 (0x283c1000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x28400000)
libm.so.5 => /lib/libm.so.5 (0x284f5000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2850a000)
libc.so.7 => /lib/libc.so.7 (0x28515000)
it seems i cannot do it. thanks!
wenhuo hu
Post by Justin Piszcz
Hello,
ldd /usr/bin/lftp
linux-gate.so.1 => (0xffffe000)
libgcc_s.so.1 => /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.2/libgcc_s.so.1 (0x40034000)
libstdc++.so.5 => /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.2/libstdc++.so.5 (0x4003d000)
libreadline.so.4 => /lib/libreadline.so.4 (0x400f3000)
libssl.so.0.9.7 => /usr/lib/libssl.so.0.9.7 (0x40121000)
libcrypto.so.0.9.7 => /usr/lib/libcrypto.so.0.9.7 (0x40152000)
libsocks.so.0 => /usr/lib/libsocks.so.0 (0x4024d000) <- You need this.
libpam.so.0 => /lib/libpam.so.0 (0x40286000)
libnsl.so.1 => /lib/libnsl.so.1 (0x4028e000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0x402a3000)
libutil.so.1 => /lib/libutil.so.1 (0x402d1000)
libresolv.so.2 => /lib/libresolv.so.2 (0x402d4000)
libdl.so.2 => /lib/libdl.so.2 (0x402e6000)
libm.so.6 => /lib/libm.so.6 (0x402e9000)
libc.so.6 => /lib/libc.so.6 (0x4030b000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
Justin.
Post by huwenhuo
hi,
I installed lftp by packages. I am using freebsd 7.1-RELEASE. My laptop
cannot afford to compile programs from source code by ports. So I do not
know whether my lftp was compiled with socks suports.
[~]$ldd /usr/local/bin/lftp
libexpat.so.6 => /usr/local/lib/libexpat.so.6 (0x2812c000)
libssl.so.5 => /usr/lib/libssl.so.5 (0x2814c000)
libcrypto.so.5 => /lib/libcrypto.so.5 (0x2818d000)
libintl.so.8 => /usr/local/lib/libintl.so.8 (0x282e6000)
libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x282ef000)
libreadline.so.7 => /lib/libreadline.so.7 (0x283e4000)
libutil.so.7 => /lib/libutil.so.7 (0x28416000)
libncurses.so.7 => /lib/libncurses.so.7 (0x28424000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x28463000)
libm.so.5 => /lib/libm.so.5 (0x28558000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2856d000)
libc.so.7 => /lib/libc.so.7 (0x28578000)
wenhuo hu
Post by Justin Piszcz
Does your lftp have socks support compiled in?
ldd /usr/bin/lftp
What does this show?
Justin.
Post by huwenhuo
Hi,
thanks Justin very much.
but it does not work.
any advice?
sincerely,
wenhuo hu
Post by Justin Piszcz
Post by huwenhuo
hi,
would anyone told me how to use socks5 proxy for lftp?
i am not sure this is the right mailing list to find things about the
usage of lftp. ^_^
thanks for any advice!
Hi,
1. You need SOCKS support compiled in.
2. Then you need to export the SOCKS5_PROXY or SOCKS_PROXY environment
variables.
Then when you use lftp it will use the socks proxy you have defined.
Justin.
huwenhuo
2009-05-15 10:06:56 UTC
Permalink
hi,

I think Freebsd port system should install other libraries automaticly.
And I looked into the packages I have been installed:

$ls /var/db/pkg |grep -i socks
csocks-1.5/
socks5-1.0.11_5/

Is that ok for compile lftp with socks?


Wenhuo Hu
Post by Justin Piszcz
You need to install the socks library first, either dante or the
original SOCKS version and its headers on your system, then try
--with-socks again.
Justin.
Post by huwenhuo
Dear Justin,
I tried to compile lftp by
make CONFIGURE_ARGS+=--with-socks5 install
but it popped up a windows for choosing the configure arguments, and
i noticed there is no socks item in that list. when it ended
installation. lftp still cannot use socks5, and the result of "ldd
/usr/local/bin/lftp" seems there is not difference before i
reinstall. it seems there are no way to set socks5 supports in freebsd?
[~]$ldd /usr/local/bin/lftp
libexpat.so.6 => /usr/local/lib/libexpat.so.6 (0x2813e000)by the w
libgnutls.so.26 => /usr/local/lib/libgnutls.so.26 (0x2815e000)
libz.so.4 => /lib/libz.so.4 (0x28205000)
libgcrypt.so.15 => /usr/local/lib/libgcrypt.so.15 (0x28217000)
libgpg-error.so.0 => /usr/local/lib/libgpg-error.so.0 (0x2827f000)
libintl.so.8 => /usr/local/lib/libintl.so.8 (0x28283000)
libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x2828c000)
libreadline.so.7 => /lib/libreadline.so.7 (0x28381000)
libutil.so.7 => /lib/libutil.so.7 (0x283b3000)
libncurses.so.7 => /lib/libncurses.so.7 (0x283c1000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x28400000)
libm.so.5 => /lib/libm.so.5 (0x284f5000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2850a000)
libc.so.7 => /lib/libc.so.7 (0x28515000)
it seems i cannot do it. thanks!
wenhuo hu
Post by Justin Piszcz
Hello,
ldd /usr/bin/lftp
linux-gate.so.1 => (0xffffe000)
libgcc_s.so.1 =>
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.2/libgcc_s.so.1 (0x40034000)
libstdc++.so.5 =>
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.2/libstdc++.so.5 (0x4003d000)
libreadline.so.4 => /lib/libreadline.so.4 (0x400f3000)
libssl.so.0.9.7 => /usr/lib/libssl.so.0.9.7 (0x40121000)
libcrypto.so.0.9.7 => /usr/lib/libcrypto.so.0.9.7 (0x40152000)
libsocks.so.0 => /usr/lib/libsocks.so.0 (0x4024d000) <- You need this.
libpam.so.0 => /lib/libpam.so.0 (0x40286000)
libnsl.so.1 => /lib/libnsl.so.1 (0x4028e000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0x402a3000)
libutil.so.1 => /lib/libutil.so.1 (0x402d1000)
libresolv.so.2 => /lib/libresolv.so.2 (0x402d4000)
libdl.so.2 => /lib/libdl.so.2 (0x402e6000)
libm.so.6 => /lib/libm.so.6 (0x402e9000)
libc.so.6 => /lib/libc.so.6 (0x4030b000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
Justin.
Post by huwenhuo
hi,
I installed lftp by packages. I am using freebsd 7.1-RELEASE. My
laptop cannot afford to compile programs from source code by ports.
So I do not know whether my lftp was compiled with socks suports.
[~]$ldd /usr/local/bin/lftp
libexpat.so.6 => /usr/local/lib/libexpat.so.6 (0x2812c000)
libssl.so.5 => /usr/lib/libssl.so.5 (0x2814c000)
libcrypto.so.5 => /lib/libcrypto.so.5 (0x2818d000)
libintl.so.8 => /usr/local/lib/libintl.so.8 (0x282e6000)
libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x282ef000)
libreadline.so.7 => /lib/libreadline.so.7 (0x283e4000)
libutil.so.7 => /lib/libutil.so.7 (0x28416000)
libncurses.so.7 => /lib/libncurses.so.7 (0x28424000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x28463000)
libm.so.5 => /lib/libm.so.5 (0x28558000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2856d000)
libc.so.7 => /lib/libc.so.7 (0x28578000)
wenhuo hu
Post by Justin Piszcz
Does your lftp have socks support compiled in?
ldd /usr/bin/lftp
What does this show?
Justin.
Post by huwenhuo
Hi,
thanks Justin very much.
but it does not work.
any advice?
sincerely,
wenhuo hu
Post by Justin Piszcz
Post by huwenhuo
hi,
would anyone told me how to use socks5 proxy for lftp?
i am not sure this is the right mailing list to find things
about the usage of lftp. ^_^
thanks for any advice!
Hi,
1. You need SOCKS support compiled in.
2. Then you need to export the SOCKS5_PROXY or SOCKS_PROXY environment
variables.
Then when you use lftp it will use the socks proxy you have defined.
Justin.
Justin Piszcz
2009-05-15 15:02:12 UTC
Permalink
socks5 should work, now recompile lftp with socks support
if it still fails, re-compile with dante (google dante socks)- it should
be able to build with one or the other.
hi,
I think Freebsd port system should install other libraries automaticly. And I
$ls /var/db/pkg |grep -i socks
csocks-1.5/
socks5-1.0.11_5/
Is that ok for compile lftp with socks?
Wenhuo Hu
Post by Justin Piszcz
You need to install the socks library first, either dante or the original
SOCKS version and its headers on your system, then try --with-socks again.
Justin.
Post by huwenhuo
Dear Justin,
I tried to compile lftp by
make CONFIGURE_ARGS+=--with-socks5 install
but it popped up a windows for choosing the configure arguments, and i
noticed there is no socks item in that list. when it ended installation.
lftp still cannot use socks5, and the result of "ldd /usr/local/bin/lftp"
seems there is not difference before i reinstall. it seems there are no
way to set socks5 supports in freebsd?
[~]$ldd /usr/local/bin/lftp
libexpat.so.6 => /usr/local/lib/libexpat.so.6 (0x2813e000)by the w
libgnutls.so.26 => /usr/local/lib/libgnutls.so.26 (0x2815e000)
libz.so.4 => /lib/libz.so.4 (0x28205000)
libgcrypt.so.15 => /usr/local/lib/libgcrypt.so.15 (0x28217000)
libgpg-error.so.0 => /usr/local/lib/libgpg-error.so.0 (0x2827f000)
libintl.so.8 => /usr/local/lib/libintl.so.8 (0x28283000)
libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x2828c000)
libreadline.so.7 => /lib/libreadline.so.7 (0x28381000)
libutil.so.7 => /lib/libutil.so.7 (0x283b3000)
libncurses.so.7 => /lib/libncurses.so.7 (0x283c1000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x28400000)
libm.so.5 => /lib/libm.so.5 (0x284f5000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2850a000)
libc.so.7 => /lib/libc.so.7 (0x28515000)
it seems i cannot do it. thanks!
wenhuo hu
Post by Justin Piszcz
Hello,
ldd /usr/bin/lftp
linux-gate.so.1 => (0xffffe000)
libgcc_s.so.1 => /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.2/libgcc_s.so.1 (0x40034000)
libstdc++.so.5 => /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.2/libstdc++.so.5
(0x4003d000)
libreadline.so.4 => /lib/libreadline.so.4 (0x400f3000)
libssl.so.0.9.7 => /usr/lib/libssl.so.0.9.7 (0x40121000)
libcrypto.so.0.9.7 => /usr/lib/libcrypto.so.0.9.7 (0x40152000)
libsocks.so.0 => /usr/lib/libsocks.so.0 (0x4024d000) <- You need this.
libpam.so.0 => /lib/libpam.so.0 (0x40286000)
libnsl.so.1 => /lib/libnsl.so.1 (0x4028e000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0x402a3000)
libutil.so.1 => /lib/libutil.so.1 (0x402d1000)
libresolv.so.2 => /lib/libresolv.so.2 (0x402d4000)
libdl.so.2 => /lib/libdl.so.2 (0x402e6000)
libm.so.6 => /lib/libm.so.6 (0x402e9000)
libc.so.6 => /lib/libc.so.6 (0x4030b000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
Justin.
Post by huwenhuo
hi,
I installed lftp by packages. I am using freebsd 7.1-RELEASE. My laptop
cannot afford to compile programs from source code by ports. So I do not
know whether my lftp was compiled with socks suports.
[~]$ldd /usr/local/bin/lftp
libexpat.so.6 => /usr/local/lib/libexpat.so.6 (0x2812c000)
libssl.so.5 => /usr/lib/libssl.so.5 (0x2814c000)
libcrypto.so.5 => /lib/libcrypto.so.5 (0x2818d000)
libintl.so.8 => /usr/local/lib/libintl.so.8 (0x282e6000)
libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x282ef000)
libreadline.so.7 => /lib/libreadline.so.7 (0x283e4000)
libutil.so.7 => /lib/libutil.so.7 (0x28416000)
libncurses.so.7 => /lib/libncurses.so.7 (0x28424000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x28463000)
libm.so.5 => /lib/libm.so.5 (0x28558000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2856d000)
libc.so.7 => /lib/libc.so.7 (0x28578000)
wenhuo hu
Post by Justin Piszcz
Does your lftp have socks support compiled in?
ldd /usr/bin/lftp
What does this show?
Justin.
Post by huwenhuo
Hi,
thanks Justin very much.
but it does not work.
any advice?
sincerely,
wenhuo hu
Post by Justin Piszcz
Post by huwenhuo
hi,
would anyone told me how to use socks5 proxy for lftp?
i am not sure this is the right mailing list to find things about
the usage of lftp. ^_^
thanks for any advice!
Hi,
1. You need SOCKS support compiled in.
2. Then you need to export the SOCKS5_PROXY or SOCKS_PROXY environment
variables.
Then when you use lftp it will use the socks proxy you have defined.
Justin.
Loading...